Intermittent 500 errors across all services
Incident Report for Addresscloud
Resolved
AWS have advised that they have resolved the issue and we are seeing all Addresscloud services are running as normal. We apologise to any inconvenience this may have caused Addresscloud customers, please be assured this was out of our hands. We will perform a post-mortem on this issue and look at how we can further improve our resiliency to this kind of incident in future.

Update from AWS: "Between 9:39 AM and 10:27 AM PDT (17:39 and 18:27 BST), we experienced increased error rates and latencies for API Gateway in the EU-WEST-1 Region... The issue has been resolved and the service is operating normally."
Posted May 16, 2022 - 18:53 BST
Monitoring
AWS have advised that the issue is in the process of being resolved and we are seeing a reduction in 500 errors: "We can confirm increased error rates and latencies for API Gateway in the EU-WEST-1 Region. Both the error rates and latencies are at a low enough level where retries would allow for a request to succeed. We have identified the root cause and are working to fully resolve the issue."
Posted May 16, 2022 - 18:33 BST
Identified
We have received the following from Amazon Web Services our hosting provider. It would appear to be an issue across all three Dublin data centres and is affecting multiple service providers. "We are investigating increased error rates and latencies for API Gateway in the EU-WEST-1 Region. Some other AWS services are also affected by this issue, which we will provide further details on shortly. We are working to determine root cause and resolve the issues."
Posted May 16, 2022 - 18:21 BST
Update
We are continuing to investigate this issue.
Posted May 16, 2022 - 17:57 BST
Investigating
We are seeing intermittent 500 errors across all Addresscloud services, our support staff are investigating now and will provide further updates
Posted May 16, 2022 - 17:56 BST
This incident affected: Addresscloud Match API and Addresscloud Intelligence API.