Match API - North America Response Times Degraded
Incident Report for Addresscloud
Resolved
Microsoft have informed us that the the issue has now been resolved and we can confirm that Addresscloud performance for North America has returned to normal
Posted Mar 22, 2019 - 11:50 GMT
Monitoring
Address lookup times are now back to normal. We are still awaiting confirmation of incident resolution from our provider Microsoft Bing, and will continue to monitor the status in the meantime.
Posted Mar 22, 2019 - 11:33 GMT
Investigating
We have been alerted to a degradation in performance on our North American address matching and geocoding service. We have escalated the issue to our provider Microsoft Bing who have confirmed this as a known issue impacting several customers. We will monitor the situation closely and keep our customers informed as we have updates.
Posted Mar 22, 2019 - 11:22 GMT
This incident affected: Addresscloud Match API.